This site is designed to work with Explorer 6 or greater. Firefox version 2.0 and Safari version 2.0

Did this answer your question?