If you're here it's because your current copy of Fabber is expired and you'll need to download the latest update. If you're still on a paid plan it's easy to do. Just go here:

You'll be downloading and setting up a fresh copy with will overwrite your old version.

Did this answer your question?