If you feel something in your Market Locator account isn’t working properly be sure to contact us at support@marketlocator.sk. There are always small mistakes hidding here and there and we would be happy if you can help us find them and get rid of them.

Technical requirements

We recommend using one of the following up-to-date browsers: Google Chrome, Firefox or Safari. We test and support our app for Internet Explorer 10 and above.

Našli jste odpověď?