The Milli app supports both iPhone (iOS 12.0 or later) and Android devices ( Android OS 5.0 or later). Make sure your phone is meeting these minimum requirements before downloading the Milli app!

Did this answer your question?