Instalace Flexi na Ubuntu 22.04 není momentálně zdánlivě možná. V závislosti na postupu, jaký pro instalaci zvolíte, narazíte na hlášku podobné této:

V repozitářích Ubuntu 22.04 je pouze PostgreSQL 14, tuto verzi ale Flexi momentálně nepodporuje. Pomůžeme si přidáním oficiálního PostgreSQL repozitáře, který obsahuje na výběr více podporovaných verzí PostgreSQL.

Stačí navštívit stránku https://www.postgresql.org/ , tam zvolit sekci Download a vybrat Váš operační systém - Ubuntu. V menu Choose your Ubuntu version zvolte možnost Jammy (22.04). Pokud se v menu nenabízí, budete muset ručně změnit verzi na jammy-pgdg.

Podle návodu založte soubor /etc/apt/sources.list.d/pgdg.list s požadovaným obsahem. Dále je potřeba přidat klíč repozitáře a pak už jen provést aktualizaci apt cache repozitářů.

POZOR: Pokud provozujete distribuce založené na Ubuntu 22.04 (např. Mint 21), bude třeba obsah pgdg.list upravit na:

deb http://apt.postgresql.org/pub/repos/apt jammy-pgdg main

Repozitáře PostgreSQL oficiálně podporují pouze Ubuntu, proto je třeba se zde tvářit, že provozujete čisté Ubuntu (jammy-pgdg).

Dále je vhodné zajistit instalaci Java 8. V systému již možná budete mít nainstalovanou Java 11, která je brána jako novější verze a proto instalace projde i s ní. Bohužel provoz na této verzi není momentálně podporován. Java 8 nainstalujete tímto příkazem:

sudo apt install openjdk-8-jre

Pak už jen stačí nainstalovat samotné Flexi:

Dále už jen zvolte typ instalace a máte hotovo, Flexi server je připraven k provozu.

Našli jste odpověď?