The current minimum version requirement for Seconds is iOS 11. This in turn means the minimum version is watchOS 5. 

If you are using the first generation of Apple Watch this is no longer supported. All other versions are.

If you are using a later version and the app is not appearing check which watchOS version you are using and update if required.

Occasionally the app will not appear despite having the correct watchOS version on your device. In these cases the problem is usually resolved by restarting both your Apple Watch and iPhone.

Did this answer your question?