ServiceTrade is available for desktops, tablets, and mobile phones.   This article covers the system requirements for office and field users.

-----------------------------------------------------------------------------------------------------------------------------

OFFICE USER:  SYSTEM REQUIREMENTS

ServiceTrade desktop is a web-based application, intended for office users such as service managers, schedulers, sales, accounting, etc.  

Continuous internet connectivity is required with a minimum download speed of 5 Mbps.

Supported browsers:

Note: Microsoft no longer updates or supports Internet Explorer.  Please upgrade to Microsoft Edge.

Supported desktop operating systems:

  • macOS 10.10 or higher
  • Windows 8 or higher
  • Fedora Linux 26 or higher

Minimum Requirements for Dispatch Board Use:

Processor:  2012 Intel Core i5 or Equivalent
Memory: 4 GB of Ram
Operating System: Windows 8.1, Mac OS 10.9.5, Ubuntu 16.04, Fedora 25 (or higher).

ServiceTrade desktop is neither recommended nor supported for iOS or Android.

-----------------------------------------------------------------------------------------------------------------------------

TECHNICIAN / FIELD USER:  SYSTEM REQUIREMENTS

The ServiceTrade mobile app allows your techs to do get the job done - clocking in and out, logging deficiencies, generating paperwork. etc - while in the field.

The mobile app is available for both iOS and Android operating systems, and can be used on either smartphones or tablets.

Cellular-capable tablets are strongly recommended, as it means techs won't have to rely on wifi to complete the work.

IMPORTANT - We list here the minimal and optimal OS and hardware for each platform, but there are other choices in between. When purchasing new devices, keep in mind that getting something that meets the minimum requirements will have have a much shorter relevant lifespan as future updates will cause them to fall behind and out of compatibility.

Minimum Requirements:

iOS

  • iOS 10.0
  • iPhone 5
  • iPad Mini (2nd gen) / iPad (4th gen)

Android

  • OS 6.0 (Marshmallow)
  • Hardware must have access to the Google Play store

Recommended:

iOS

  • iOS 12.0
  • iPhone 6s or newer
  • iPad (5th gen) or newer

Android

  • OS 8.0 (Pie)
  • Google Pixel 1 or newer
  • Samsung Galaxy Tab S3/4

-----------------------------------------------------------------------------------------------------------------------------

Q&A:

Which device should I get for the field?

  • We strongly recommend cellular iPads.

Why do you recommend iPads?

  • Consistently better cellular strength.
  • Consistent software across various sizes and devices.
  • Regular OS updates.
  • Support history.
  • Customer feedback.

Is there a mobile "admin" app?

  • No.  The mobile app is intended for technician/field use only.
  • Office users should use app.servicetrade.com, from a desktop/laptop class device running Windows 10, macOS, Linux, or Chrome OS.

Did this answer your question?