CNAMES are great, but they can be finicky. Here is a troubleshooting guide to see if you can get it working.

Troubleshooting CNAME

Troubleshooting Problems With Your CNAME Record

If you've followed the steps above and are still experiencing difficulties, you can quickly verify your CNAME record using a web based dig tool.

The results show you:

  • Type
  • If your DNS settings are correct, you will see 'CNAME' in this field
  • If you do not see 'CNAME' in the response and only see 'A' then there may be an A Record in your DNS that is overriding your CNAME Record. This A Record will need to be deleted or changed because you cannot have an A Record and a CNAME record created for the same subdomain.
  • Domain Name - the domain you searched
  • Canonical Name - the host your domain points to
  • If your DNS settings are correct, you will see "simplebooklet.com" in this field
  • If you see a different value, you will have to edit the host (or points to) value of this subdomain in your DNS settings to be "simplebooklet.com"
  • Note: you might see something like "simplebooklet.com.yourdomain.com" in this field. If you do, you'll have to return to your host and edit the points to value of your CNAME record to be "simplebooklet.com." (note the extra . at the end)
  • TTL
  • This is the amount of time your server holds on to older cached information before it refreshes to show any new changes. If your custom domain does not seem to be working properly, you may just need to wait the amount of time indicated before your custom domain will work.

Once your CNAME is fully propagated (working), head back to the Dashboard and tap the ADD button for Custom Domain.

Did this answer your question?