Sprout Studio is a modern, responsive, and mobile friendly, cloud-based web software. The following are the minimum system requirements to fully enjoy every aspect of Sprout Studio:

  • Internet Explorer 11+
  • Google Chrome: latest version
  • Mozilla Firefox: latest version
  • Apple Safari: 7+

We recommend using the latest version of Google Chrome on Windows, Mac, or Linux to have the most secure and fastest Sprout Studio experience.

If you need help updating your browser, or your client’s, please visit: http://outdatedbrowser.com/en

Did this answer your question?