If you are working with the Java SDK and creating addons or coded tests, you might get this error in your console: 

"java.lang.RuntimeException: Your SDK version is incompatible with this Agent, please use a newer version"


As this error says, you must update your SDK version to the latest one. Every time we release a major version (0.58, 0.59, etc.), a new SDK version is also released with a matching version number. So, simply download the new SDK version from here and replace it with the existing one in your machine.

Still need help? Feel free to reach out to us at any time in the Chat or Forum. Or explore more in our official Documentation 😉🎓

Did this answer your question?