We support testing with virtual browsers using:

  • Chrome*

  • Firefox*

  • Internet Explorer (10-11)*

*For latest version details, check with us using the customer support chat. Note that Usetrace is built on Selenium and may not be able to support any higher browser versions than Selenium.

Did this answer your question?