We support the newest versions of all major browsers. Wipster relies on some pretty fancy technology and asks quite a lot of your web browser. If you haven't updated your browser for a long time, you might start seeing some issues, and at at a certain point, you won't be able to log in.

Here's a canonical list of the browsers we currently support (latest versions).

  • Internet Explorer

  • Microsoft Edge

  • Safari

  • Chrome

  • Firefox

If your browser is not in this list and you'd like it to be, please let us know.

Did this answer your question?