If you encounter a blank or error page when visiting 192.168.8.1 - this should provide the fix...

1 - Stuck on 'Waiting for you to Reconnect'?

If Pyramid Setup is stuck on a 'Waiting for you to Reconnect' message but you are already connected in WiFi Settings - visit 192.168.8.1 or try the Pyramid App instead to see if that provides a fix.

2 - Check Power or Reboot

A quick thing to check is that Pyramid is getting enough power - try a different power adaptor (plug) or USB cable to make sure or do a quick reboot (disconnect from power, reconnect, then wait 60 seconds) then retry.

3 - Clear Cache or Try Another Device

In case of a browser issue, you can try to clear your browser cache (tap here to see how). Or alternatively, you can try another smartphone or tablet to see if this issue is specific to your device or could be caused by some other software (such as another VPN or Firewall app).

4 - Factory Reset

If you've tried these steps and it still won't load we'd recommend a quick factory reset - tap here to learn how.


If you see 'Connected, no internet' in WiFi Settings during a first-time connection that is expected until you pair it with the internet. Just open your browser and head over to 192.168.8.1


Other issues

If both 192.168.8.1 is not loading, there could be a IP LAN conflict, I would suggest you visit ... link to be inserted to learn how to fix the issue.

Need some help?

If these tips don't fix it for you, pop us a message at pyramidwifi.com/help and we'll be happy to help!


Still have an issue?
Pop us an email to help@pyramidwifi.com or tap the message button on the bottom right of this page to get in touch.

Did this answer your question?