All Collections
Estimates & Work Orders
Instances when a Work Order does not appear in the Calendar
Instances when a Work Order does not appear in the Calendar

Customer not Active? Work Pool? Service Agreement Pending or Expired...

Beau O'Hara avatar
Written by Beau O'Hara
Updated over a week ago

Summary

There are many reasons why a Work Order does not appear in the Calendar. Investigate the Work Order and the parameters about it to identify the issue.

Key Points

Reasons why a Work Order does not appear in the Calendar include:

  1. Customer/Location is not Active

  2. Work Order is in the Work Pool

  3. Appointment is scheduled outside of the Calendar Start/End time

  4. Calendar Filters are not properly selected

  5. Technician has been deactivated and work has not been reassigned

  6. A Service Agreement is set to Pending or Draft

  7. A Service Agreement Renewal has expired

  8. A service in Settings/Services was renamed or deleted

  9. You're not looking at the correct day

  10. Change completed date is selected in Settings/Work Orders

  11. Mobile: Customer and tech are not in the same branch

  12. Mobile: The tech is not logged in as himself/herself

  13. Mobile: The device is offline

Customer is not Active

The customer status is Inactive, Financial Hold, or Sent to Collections. Look for the customer's status in the upper-left hand corner of the customer's billing page.

To make the customer Active, click the Edit button in the upper-right area of the Billing Page, and change the status to Active.

Location is not Active

The location is Deactivated. To Activate the location, click the down arrow to the right of the View button, and Activate the location.

Work Order is in the Work Pool

When creating a Work Order you can schedule it for the Work Pool from the Schedule tab.

Work Pool is best for accounts when you can arrive at any time (commercial, external), or your call-to service customers. Putting an appointment in the Work Pool takes it out of the Calendar so you may schedule at any time.

For more information about the Work Pool, see: Work Pool - getting started

Appointment is scheduled outside of the Calendar Start/End time

If you have your Calendar's start and end times set to normal business hours, such as 8AM to 5PM and an appointment is scheduled outside of those hours, 5AM or 7PM, for example, the appointment will not appear. 

Temporarily set your Settings/Calendar & Time start and end times to start at 12AM and end at 11:45 PM to see those appointments.

Calendar Filters are not properly selected

You might have selected/unselected various Calendar Filters that keep all Work Orders from appearing.

Click each Filter and make sure all selections are checked. Selections that are not checked do not appear in the Calendar.

Technician has been deactivated and work has not been reassigned

When a technician is deactivated, all the work assigned to that technician is removed from the calendar. After deactivating a tech:

  • Move the work from the deactivated tech to an existing tech

OR

  • Create a new tech 

  • Move the work from the deactivated tech to the new tech

For more information regarding how to do this, see: Deactivate a User/Route

A Service Agreement is set to Pending or Draft

A Service Agreement needs to be set to Active for its Work Order to be in the Calendar. Click the Edit button to the right of the Status and change the Status to Active.

A Service Agreement Renewal has expired

If the Renewal date has passed and expired, as indicated by the minus sign in front of the number of days, the Work Order will not be in the Calendar. Edit the Agreement and update the Renewal date.

For more information about Service Agreements, see the following articles:
Service Agreements - Part 1
Service Agreements - Part 2
Service Agreements - Part 3

A service in Settings/Services was renamed or deleted

If you rename or delete a service in Settings/Services, the Work Orders that contain that service no longer appear in the Calendar. Update the Work Orders that have the renamed or deleted service to a service that exists in Settings/Services. To do this:

  1. If the service was renamed, the quick fix is to name it back to what it was; otherwise...

  1. Filter the date range to show all Work Orders that fit the criteria for the missing service (for example, if it was a quarterly service, filter out three months, a monthly service, filter out one month...)

  2. Filter the Service Type to the missing service and click Filter

  3. Right click the Service Location of an account

  4. In the newly opened tab, click the Edit Series button for that service

  5. Update the service to an existing service, and click Update Series

  6. Repeat with others

You're not looking at the correct day

It happens. Make sure you're on the correct day.

Change completed date is selected in Settings/Work Orders

Go to Settings/Work Orders and scroll down the page.

[x] Change completed date (online) or (mobile) is selected. When completing a work order in the past or the future this option will update the scheduled date to the day of completion.

In other words, go to the day in the Calendar to find those Work Orders. If it's July 30 and you're making changes on that day, go to July 30 in the Calendar to find the Work Orders.

Mobile: Customer and tech are not in the same branch

If you can see the Work Order in the online Calendar, but the tech can't see it in the mobile app, check the following:

  1. Edit the customer's billing page and scroll down to Branch and note which branch the customer is in

    2. Look at the tech's user page, the branch the tech is in is shown in the upper-right
        corner 

If there is a mismatch, either:

Change the customer's branch to match the tech's branch.
-or-
Update the tech's branch to include the customer's branch.

Either way, reload data on the mobile app to see the appointment.

Mobile: The tech is not logged in as himself/herself

Log out of the app and verify the email address is the tech's email address.

Mobile: The device is offline

From the Calendar, have the tech tap the menu in the upper left (the three horizontal lines). Tap Settings and make sure the slider for Offline mode is grey.

Make sure the Internet connection icons at the top of the device screen are there.

Did this answer your question?